IPv6 EIGRP functions similarly to IPv4 EIGRP but operates independently. In this lesson, first we’ll start by configuring classic EIGRP separately for IPv4 and IPv6 on a sample dual-protocol topology. Then, we’ll explore name-based EIGRP, which allows both protocols to be managed within a unified configuration context, while still maintaining independent operation.

Table of Contents

IPv6 EIGRP Fundamental

EIGRP for IPv4 only handles IPv4 updates, so a separate protocol version was developed for IPv6, largely retaining the same concepts and configuration syntax. Assuming you’re already familiar with EIGRP, we’ll focus here on a few key differences in EIGRP for IPv6.

Feature EIGRP for IPv4 EIGRP for IPv6
Protocol Updates Handles IPv4 updates only Handles IPv6 updates only
Router ID Requirement Uses a 32-bit router ID Requires manual router ID configuration in IPv6-only environments
Automatic Summarization Supported (though often disabled) Not supported
Authentication Limited authentication options Supports IPsec for enhanced security
Configuration Syntax Uses network command to activate interfaces Configured at the interface level

For instance, while EIGRP for IPv6 sends IPv6 updates, it still requires a 32-bit router ID, which means you’ll need to set the router ID manually in native IPv6 environments.

Additionally, IPv6 EIGRP doesn’t support automatic summarization—though this feature has become less relevant in recent years.

Finally, EIGRP for IPv6 offers enhanced security by using IPsec for authentication, providing stronger encryption and authentication methods than its IPv4 counterpart.

Classic IPv6 EIGRP Configuration

If you want to configure EIGRP for both IPv4 and IPv6, most vendors require fully independent configurations for each protocol. They maintain separate topology tables, databases, processes, and routing tables, with no information shared between the IPv4 and IPv6 stacks.

Topology Description

To illustrate this, I’ve prepared a dual-stack topology where we’ll configure EIGRP for both IPv4 and IPv6 independently.

Classic EIGRP Configuration
Classic EIGRP Configuration

In this topology, two branch offices are connected via a central office. The connection between the central office and Branch1 uses the IPv4 address range 10.0.1.0/24 and the IPv6 prefix 2001:AA:0:1::/64. Similarly, the link between the central office and Branch2 is configured with the IPv4 address range 10.0.2.0/24 and IPv6 prefix 2001:AA:0:2::/64.

The loopback interfaces for Branch1 and Branch2 are assigned IPv4 address ranges of 10.1.1.0/24 and 10.2.2.0/24, respectively, with IPv6 prefixes 2001:AA:1::/64 for Branch1 and 2001:AA:2::/64 for Branch2.

IPv4 EIGRP Configuration

First, we configure EIGRP for the IPv4 topology. In IPv4 EIGRP, we activate interfaces using the „network command. We manually set the router ID and enable summarization at the interface level on the branch routers. Finally, we set the loopback interfaces as passive to prevent EIGRP packets from being sent over these interfaces.

## HQ
router eigrp 1
 network 10.0.0.0 0.0.255.255
 eigrp router-id 10.10.10.10
## BR1
router eigrp 1
 network 10.0.0.0
 passive-interface Loopback0
 eigrp router-id 1.1.1.1
!
interface Ethernet0/0
 ip summary-address eigrp 1 10.1.0.0 255.255.0.0
## BR2
router eigrp 1
 network 10.0.0.0
 passive-interface Loopback0
 eigrp router-id 2.2.2.2
!
interface Ethernet0/0
 ip summary-address eigrp 1 10.2.0.0 255.255.0.0

The monitoring commands „show ip eigrp neighbors, „show ip eigrp topology, and „show ip route eigrp are among the most commonly used commands for managing and troubleshooting the EIGRP protocol.

HQ#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   10.0.2.2                Et0/1                    13 00:06:02    9   100  0  6
0   10.0.1.1                Et0/0                    14 00:06:11    3   100  0  9
HQ#show ip eigrp topology
EIGRP-IPv4 Topology Table for AS(1)/ID(10.10.10.10)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.0.1.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/0
P 10.1.0.0/16, 1 successors, FD is 409600
        via 10.0.1.1 (409600/128256), Ethernet0/0
P 10.2.0.0/16, 1 successors, FD is 409600
        via 10.0.2.2 (409600/128256), Ethernet0/1
P 10.0.2.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/1
HQ#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
D        10.1.0.0/16 [90/409600] via 10.0.1.1, 00:06:17, Ethernet0/0
D        10.2.0.0/16 [90/409600] via 10.0.2.2, 00:06:08, Ethernet0/1

IPv6 EIGRP Configuration

IPv6 EIGRP configuration syntax is similar to IPv4 EIGRP but operates independently. The main difference is that, in IPv6 EIGRP, interfaces are activated at the interface level rather than with thenetwork command. The router ID in IPv6 EIGRP remains 32-bit, and it’s recommended to configure it manually, especially since there may be no IPv4 address assigned to the interfaces.

## HQ
ipv6 router eigrp 1
 eigrp router-id 10.10.10.10
!
interface Ethernet0/0
 ipv6 eigrp 1
!
interface Ethernet0/1
 ipv6 eigrp 1
## BR1
ipv6 router eigrp 1
 passive-interface Loopback0
 eigrp router-id 1.1.1.1
!
interface Ethernet0/0
 ipv6 eigrp 1
 ipv6 summary-address eigrp 1 2001:AA:1::/48
!
interface Loopback0
 ipv6 eigrp 1
## BR2
ipv6 router eigrp 1
 passive-interface Loopback0
 eigrp router-id 2.2.2.2
!
interface Ethernet0/0
 ipv6 eigrp 1
 ipv6 summary-address eigrp 1 2001:AA:2::/48
!
interface Loopback0
 ipv6 eigrp 1

The same monitoring commands used in IPv4 EIGRP can also be applied in IPv6 EIGRP, with the only difference being that the keyword „ipv6 replaces „ip.

HQ#show ipv6 eigrp neighbors
EIGRP-IPv6 Neighbors for AS(1)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   Link-local address:     Et0/1                    13 00:05:55   10   100  0  9
    FE80::2
0   Link-local address:     Et0/0                    14 00:06:04    8   100  0  10
    FE80::1
HQ#show ipv6 eigrp topology
EIGRP-IPv6 Topology Table for AS(1)/ID(10.10.10.10)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 2001:AA:0:1::/64, 1 successors, FD is 281600
        via Connected, Ethernet0/0
P 2001:AA:0:2::/64, 1 successors, FD is 281600
        via Connected, Ethernet0/1
P 2001:AA:1::/48, 1 successors, FD is 409600
        via FE80::1 (409600/128256), Ethernet0/0
P 2001:AA:2::/48, 1 successors, FD is 409600
        via FE80::2 (409600/128256), Ethernet0/1
HQ#show ipv6 route eigrp
IPv6 Routing Table - default - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, ls - LISP site
       ld - LISP dyn-EID, a - Application
D   2001:AA:1::/48 [90/409600]
     via FE80::1, Ethernet0/0
D   2001:AA:2::/48 [90/409600]
     via FE80::2, Ethernet0/1

Name based EIGRP Configuration

Another method for configuring EIGRP in both IPv4 and IPv6 is using named EIGRP configuration. The advantage of this approach is that it allows configuration for both IPv4 and IPv6 EIGRP within a unified configuration context, even though the protocols remain independent.

Name based EIGRP Configuration
Name based EIGRP Configuration

A further benefit of named EIGRP configuration is that interface-level settings can be applied without leaving the EIGRP configuration context, eliminating the need to switch between the EIGRP and interface configuration modes. Additionally, with the “default” keyword, you can apply EIGRP settings to all interfaces simultaneously, avoiding the need to configure each interface individually.

!!! HQ
router eigrp RAYKA
 !
 address-family ipv4 unicast autonomous-system 1
  !
  af-interface default
   hello-interval 1
   hold-time 3
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 10.0.0.0
  eigrp router-id 10.10.10.10
 exit-address-family
 !
 address-family ipv6 unicast autonomous-system 1
  !
  af-interface default
   hello-interval 1
   hold-time 3
  exit-af-interface
  !
  topology base
  exit-af-topology
  eigrp router-id 10.10.10.10
 exit-address-family
!!! BR1
router eigrp RAYKA
 !
 address-family ipv4 unicast autonomous-system 1
  !
  af-interface default
   hello-interval 1
   hold-time 3
  exit-af-interface
  !
  af-interface Loopback0
   passive-interface
  exit-af-interface
  !
  af-interface Ethernet0/0
   summary-address 10.1.0.0 255.255.0.0
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 10.0.0.0
  eigrp router-id 1.1.1.1
 exit-address-family
 !
 address-family ipv6 unicast autonomous-system 1
  !
  af-interface default
   hello-interval 1
   hold-time 3
  exit-af-interface
  !
  af-interface Loopback0
   passive-interface
  exit-af-interface
  !
  af-interface Ethernet0/0
   summary-address 2001:AA:1::/48
  exit-af-interface
  !
  topology base
  exit-af-topology
  eigrp router-id 1.1.1.1
 exit-address-family
!!! BR2
router eigrp RAYKA
 !
 address-family ipv4 unicast autonomous-system 1
  !
  af-interface default
   hello-interval 1
   hold-time 3
  exit-af-interface
  !
  af-interface Loopback0
   passive-interface
  exit-af-interface
  !
  af-interface Ethernet0/0
   summary-address 10.2.0.0 255.255.0.0
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 10.0.0.0
  eigrp router-id 2.2.2.2
 exit-address-family
 !
 address-family ipv6 unicast autonomous-system 1
  !
  af-interface default
   hello-interval 1
   hold-time 3
  exit-af-interface
  !
  af-interface Loopback0
   passive-interface
  exit-af-interface
  !
  af-interface Ethernet0/0
   summary-address 2000::/4
  exit-af-interface
  !
  topology base
  exit-af-topology
  eigrp router-id 2.2.2.2
 exit-address-family

The monitoring commands are the same for both classic EIGRP configuration and named EIGRP configuration; there are no differences in how they are used.

show ip eigrp neighbors
show ip eigrp topology
show ip protocols
show ip route eigrp
show ipv6 eigrp neighbors
show ipv6 eigrp topology
show ipv6 protocols
show ipv6 route eigrp
Back to: IPv6 (in progress) > IPv6 Routing

Leave a Reply

Your email address will not be published. Required fields are marked *


Post comment