IS-IS IPv6 multi-topology configuration in a dual-stack topology is the main focus of this section. We will start with a brief overview of the differences between IS-IS for IPv6 and IPv4 although IS-IS requires minimal changes to support IPv6 compared to OSPF and EIGRP, it introduces a new TLV to transport IPv6 addresses and topologies.

ISIS in IPv6

IS-IS, unlike OSPF and EIGRP, required minimal changes to support IPv6. This was achieved by introducing new TLVs (Type-Length-Values) to transport IPv6 addresses and topology information seamlessly.

By default, IS-IS operates in single-topology mode, where a single LSP (Link-State PDU) packet, a unified database, and a single SPF (Shortest Path First) process are used for both IPv4 and IPv6. In this mode, all routers and interfaces within the topology must support both IPv4 and IPv6, and the link metrics for both protocols must be identical.

To provide greater flexibility, IS-IS also supports multi-topology mode, where separate LSP packets are generated for IPv4 and IPv6. This results in distinct databases and SPF processes for each protocol. Multi-topology mode is particularly useful during IPv6 migration scenarios or when the IPv4 and IPv6 topologies and metrics differ, as it allows independent management of both.

Aspect Single-Topology Mode Multi-Topology Mode
LSP (Link-State PDU) Packets Shared LSP packets for both IPv4 and IPv6, with different TLVs to carry protocol-specific information. Separate LSP packets are generated for IPv4 and IPv6, each carrying its respective topology information.
Routing Information IPv4 and IPv6 share the same link-state database and routing information. Independent link-state databases and routing information are maintained for IPv4 and IPv6.
SPF Process Single SPF process is used for both IPv4 and IPv6, as the topology is unified. Separate SPF processes are used for IPv4 and IPv6, allowing independent computation.
Metrics Requires identical metrics for both IPv4 and IPv6. Allows independent metrics for IPv4 and IPv6.
Topology Dependency Both IPv4 and IPv6 must operate on the same physical topology. IPv4 and IPv6 can operate on separate topologies.
Use Case Suitable when all routers and links support both IPv4 and IPv6, with identical metrics. Useful for gradual IPv6 migration or when IPv4 and IPv6 topologies differ.

To facilitate better understanding, I have already set up a dual-stack topology in which we configure IS-IS in multi-topology mode to independently manage IPv4 and IPv6 routing. I will not go into the details of the IS-IS protocol itself, as I assume you are already familiar with it. Instead, I will focus specifically on the aspects of IS-IS that relate to IPv6.

IS-IS IPv6 multi-topology configuration Example

In this topology, there are three routers: IOU2 and IOU3 are connected to a central office via IOU1. All links are addressed with both IPv4 and IPv6.

IS-IS IPv6 multi-topology configuration example
IS-IS IPv6 multi-topology configuration example

To configure IS-IS in multi-topology mode, we begin by configuring an IS-IS instance. In this example, I have used the command „router isis RAYKA“ to define the instance. Next, I assigned a unique NET address to each router and enabled IS-IS Level 1 on all routers.

To enable IS-IS multi-topology, we first need to activate the wide metric by using the command „metric-style wide“. Once the wide metric is enabled, we can then activate multi-topology by using the „multi-topology“ keyword in the „address-family ipv6“ configuration.

For enabling IS-IS on IPv4 interfaces, the command „ip router isis RAYKA“ is used, and for IPv6 interfaces, the command is „ipv6 router isis RAYKA“.

Additionally, I configured different IS-IS metrics for IPv4 and IPv6 to demonstrate that, in multi-topology IS-IS, you can use different metrics for each topology.

!!! IOU1
ipv6 unicast-routing
!
router isis RAYKA
 net 49.0000.0000.0000.0001.00
 is-type level-1
 metric-style wide
 !
 address-family ipv6
  multi-topology
 exit-address-family
!
interface Ethernet0/0
 ip address 10.1.2.1 255.255.255.0
 ip router isis RAYKA
 ipv6 address 2001:AA:1:2::1/64
 ipv6 router isis RAYKA
 isis metric 10
 isis ipv6 metric 20
!
interface Ethernet0/1
 ip address 10.1.3.1 255.255.255.0
 ip router isis RAYKA
 ipv6 address 2001:AA:1:3::1/64
 ipv6 router isis RAYKA
 isis metric 10
 isis ipv6 metric 20
!!! IOU2
router isis RAYKA
 net 49.0000.0000.0000.0002.00
 is-type level-1
 metric-style wide
 !
 address-family ipv6
  multi-topology
 exit-address-family
!
interface Ethernet0/0
 ip address 10.1.2.2 255.255.255.0
 ip router isis RAYKA
 ipv6 address 2001:AA:1:2::2/64
 ipv6 router isis RAYKA
 isis metric 10
 isis ipv6 metric 20
!
interface Loopback0
 ip address 10.2.2.2 255.255.255.0
 ip router isis RAYKA
 ipv6 address 2001:AA:2:2::2/64
 ipv6 router isis RAYKA
 isis metric 10
 isis ipv6 metric 20
!!! IOU3
router isis RAYKA
 net 49.0000.0000.0000.0003.00
 is-type level-1
 metric-style wide
 !
 address-family ipv6
  multi-topology
 exit-address-family
!
interface Ethernet0/0
 ip address 10.1.3.3 255.255.255.0
 ip router isis RAYKA
 ipv6 address 2001:AA:1:3::3/64
 ipv6 router isis RAYKA
 isis metric 10
 isis ipv6 metric 20
!
interface Loopback0
 ip address 10.3.3.3 255.255.255.0
 ip router isis RAYKA
 ipv6 address 2001:AA:3:3::3/64
 ipv6 router isis RAYKA
 isis metric 10
 isis ipv6 metric 20

Verify ISIS operation

To verify the operation of the IS-IS protocol, we first check the IS-IS neighborship, which is established based on Hello packets. IS-IS packets, including Hello packets, are transmitted using CLNS addresses. This means the same Hello packets are used for both IPv4 and IPv6 addresses. Consequently, there is no separate neighbor table for IPv4 and IPv6; instead, a single neighbor table is maintained for both.

You can verify the neighborship in IS-IS by using the commands „show clns neighbors [detail]“ or „show isis neighbors [detail]“. These commands display detailed information about IS-IS neighbors.

IOU1#show clns neighbors

Tag RAYKA:
System Id      Interface   SNPA                State  Holdtime  Type Protocol
IOU2           Et0/0       aabb.cc00.0200      Up     9         L1   M-ISIS
IOU3           Et0/1       aabb.cc00.0300      Up     9         L1   M-ISIS
IOU1#show clns neighbors detail

Tag RAYKA:
System Id      Interface   SNPA                State  Holdtime  Type Protocol
IOU2           Et0/0       aabb.cc00.0200      Up     7         L1   M-ISIS
  Area Address(es): 49.0000
  IP Address(es):  10.1.2.2*
  IPv6 Address(es): FE80::A8BB:CCFF:FE00:200
  Uptime: 14:27:13
  NSF capable
  Topology: IPv4, IPv6
  Interface name: Ethernet0/0
IOU3           Et0/1       aabb.cc00.0300      Up     8         L1   M-ISIS
  Area Address(es): 49.0000
  IP Address(es):  10.1.3.3*
  IPv6 Address(es): FE80::A8BB:CCFF:FE00:300
  Uptime: 14:38:40
  NSF capable
  Topology: IPv4, IPv6
  Interface name: Ethernet0/1
IOU1#show isis neighbors detail

Tag RAYKA:
System Id      Type Interface   IP Address      State Holdtime Circuit Id
IOU2           L1   Et0/0       10.1.2.2        UP    8        IOU2.01
  Area Address(es): 49.0000
  SNPA: aabb.cc00.0200
  IPv6 Address(es): FE80::A8BB:CCFF:FE00:200
  State Changed: 00:02:44
  LAN Priority: 64
  Format: Phase V
  Remote TID: 0, 2
  Local TID:  0, 2
  Interface name: Ethernet0/0
IOU3           L1   Et0/1       10.1.3.3        UP    7        IOU3.01
  Area Address(es): 49.0000
  SNPA: aabb.cc00.0300
  IPv6 Address(es): FE80::A8BB:CCFF:FE00:300
  State Changed: 00:14:11
  LAN Priority: 64
  Format: Phase V
  Remote TID: 0, 2
System Id      Type Interface   IP Address      State Holdtime Circuit Id
  Local TID:  0, 2
  Interface name: Ethernet0/1

Topology and address information in IS-IS are sent through LSP (Link-State PDU) packets, which are used for both IPv4 and IPv6. In single-topology mode, the same LSP packets are shared for both protocols, but different TLVs (Type-Length-Values) are used to carry IPv4 and IPv6-specific information.

In multi-topology mode, separate LSP packets are generated for each topology. This means distinct LSPs are created for IPv4 and IPv6, with each carrying information specific to its respective protocol. This ensures that routing information for IPv4 and IPv6 is maintained and managed independently.

In single-topology mode, IS-IS uses a single SPF process for both IPv4 and IPv6. Since the topology is unified, a single link-state database is used, and SPF computation is performed only once for both protocols.

In contrast, in multi-topology mode, IS-IS uses separate SPF processes for IPv4 and IPv6. Each protocol has its own link-state database and topology, allowing independent metrics and topologies. This mode is particularly beneficial during IPv6 migration or when the IPv4 and IPv6 topologies differ.

You can verify the IS-IS database related to the IPv4 topology using the command:
show isis database detail ip

To check the IS-IS database for the IPv6 topology, use the command:
show isis database detail ipv6

IOU1#show isis database detail ip

Tag RAYKA:
IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
IOU1.00-00          * 0x00000013   0xD032        1035              0/0/0
  Area Address: 49.0000
  Topology:     IPv4 (0x0)
  NLPID:        0xCC 0x8E
  Hostname: IOU1
  IP Address:   10.1.3.1
  Metric: 10         IP 10.1.3.0/24
  Metric: 10         IP 10.1.2.0/24
  IPv6 Address: 2001:AA:1:3::1
  Metric: 10         IS-Extended IOU2.01
  Metric: 10         IS-Extended IOU3.01
IOU2.00-00            0x0000000A   0x47FE        1034              0/0/0
  Area Address: 49.0000
  Topology:     IPv4 (0x0)
  NLPID:        0xCC 0x8E
  Hostname: IOU2
  IP Address:   10.2.2.2
  Metric: 10         IP 10.2.2.0/24
  Metric: 10         IP 10.1.2.0/24
  IPv6 Address: 2001:AA:2:2::2
  Metric: 10         IS-Extended IOU2.01
IOU2.01-00            0x00000003   0x60E0        931               0/0/0
  Metric: 0          IS-Extended IOU2.00
  Metric: 0          IS-Extended IOU1.00
IOU3.00-00            0x00000007   0xE454        940               0/0/0
  Area Address: 49.0000
  Topology:     IPv4 (0x0)
  NLPID:        0xCC 0x8E
  Hostname: IOU3
  IP Address:   10.3.3.3
  Metric: 10         IP 10.1.3.0/24
  Metric: 10         IP 10.3.3.0/24
  IPv6 Address: 2001:AA:3:3::3
  Metric: 10         IS-Extended IOU3.01
IOU3.01-00            0x00000003   0x61DD        1001              0/0/0
  Metric: 0          IS-Extended IOU3.00
  Metric: 0          IS-Extended IOU1.00
IOU1#show isis database detail ipv6

Tag RAYKA:
IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
IOU1.00-00          * 0x00000013   0xD032        1031              0/0/0
  Area Address: 49.0000
  Topology:     IPv6 (0x2)
  NLPID:        0xCC 0x8E
  Hostname: IOU1
  IP Address:   10.1.3.1
  IPv6 Address: 2001:AA:1:3::1
  Metric: 20         IPv6 (MT-IPv6) 2001:AA:1:2::/64
  Metric: 20         IPv6 (MT-IPv6) 2001:AA:1:3::/64
  Metric: 20         IS (MT-IPv6) IOU2.01
  Metric: 20         IS (MT-IPv6) IOU3.01
IOU2.00-00            0x0000000A   0x47FE        1030              0/0/0
  Area Address: 49.0000
  Topology:     IPv6 (0x2)
  NLPID:        0xCC 0x8E
  Hostname: IOU2
  IP Address:   10.2.2.2
  IPv6 Address: 2001:AA:2:2::2
  Metric: 20         IPv6 (MT-IPv6) 2001:AA:1:2::/64
  Metric: 20         IPv6 (MT-IPv6) 2001:AA:2:2::/64
  Metric: 20         IS (MT-IPv6) IOU2.01
IOU2.01-00            0x00000003   0x60E0        927               0/0/0
IOU3.00-00            0x00000007   0xE454        935               0/0/0
  Area Address: 49.0000
  Topology:     IPv6 (0x2)
  NLPID:        0xCC 0x8E
  Hostname: IOU3
  IP Address:   10.3.3.3
  IPv6 Address: 2001:AA:3:3::3
  Metric: 20         IPv6 (MT-IPv6) 2001:AA:1:3::/64
  Metric: 20         IPv6 (MT-IPv6) 2001:AA:3:3::/64
  Metric: 20         IS (MT-IPv6) IOU3.01
IOU3.01-00            0x00000003   0x61DD        997               0/0/0
Back to: IPv6 (in progress) > IPv6 Routing

Leave a Reply

Your email address will not be published. Required fields are marked *


Post comment